博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
hdu 1880 hdoj 1880
阅读量:4122 次
发布时间:2019-05-25

本文共 1748 字,大约阅读时间需要 5 分钟。

魔咒词典

Time Limit: 8000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6773    Accepted Submission(s): 1703
Problem Description
哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。
给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”
 
Input
首先列出词典中不超过100000条不同的魔咒词条,每条格式为:
[魔咒] 对应功能
其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。
 
Output
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”
 
Sample Input
[expelliarmus] the disarming charm[rictusempra] send a jet of silver light to hit the enemy[tarantallegra] control the movement of one's legs[serpensortia] shoot a snake out of the end of one's wand[lumos] light the wand[obliviate] the memory charm[expecto patronum] send a Patronus to the dementors[accio] the summoning charm@END@4[lumos]the summoning charm[arha]take me to the sky
 
Sample Output
light the wandacciowhat?what?

#include<stdio.h>

#include<string.h>
#include<cstdlib>
#include<map>
#include<iostream>
#include<string>
using namespace std;
int main(){
    string gongneng,id,temp;
    int n;
    pair<string,string> q,p;
    map<string,string> mp;
    while(cin>>q.first){
        if(q.first=="@END@") break;
        getchar();
        getline(cin,q.second);
        p.first=q.second,p.second=q.first;
        mp.insert(q);
        mp.insert(p);
    }
    scanf("%d",&n);
    getchar();
    while(n--){
        getline(cin,temp);
        map<string,string>::iterator it=mp.find(temp);
        if(it!=mp.end()){
            if(it->second[0]=='['){
                for(int i=1;i<it->second.size()-1;i++){
                    cout<<it->second[i];
                }
                cout<<endl;
            }
            else cout<<it->second<<endl;
        }
        else if(it==mp.end()){
            cout<<"what?"<<endl;
        }
    }
    return 0;
}

转载地址:http://dxtpi.baihongyu.com/

你可能感兴趣的文章
nginx反代 499 502 bad gateway 和timeout
查看>>
linux虚拟机安装tar.gz版jdk步骤详解
查看>>
python猜拳游戏
查看>>
python实现100以内自然数之和,偶数之和
查看>>
python数字逆序输出及多个print输出在同一行
查看>>
苏宁产品经理面经
查看>>
百度产品经理群面
查看>>
去哪儿一面+平安科技二面+hr面+贝贝一面+二面产品面经
查看>>
element ui 弹窗在IE11中关闭时闪现问题修复
查看>>
vue 遍历对象并动态绑定在下拉列表中
查看>>
Vue动态生成el-checkbox点击无法选中的解决方法
查看>>
python __future__
查看>>
MySQL Tricks1
查看>>
python 变量作用域问题(经典坑)
查看>>
pytorch
查看>>
pytorch(二)
查看>>
pytorch(三)
查看>>
pytorch(四)
查看>>
pytorch(5)
查看>>
ubuntu相关
查看>>